Sorry, your web browser or operating system does not support TLS 1.2, a key security protocol.

At Vendini, keeping your data safe is one of our top priorities. As a member of the PCI Security Standards Council, we are required to make system-wide improvements that allow us to uphold our high security requirements.

  1. If you are using an outdated operating system, you may need to upgrade to one of the following:
  2. If you are using an outdated browser, please update to one of the following:
  3. Vendini Members: If you are receiving this message while trying to log in to TicketAgent on a Mac and have already completed the above, please update TicketAgent. Click here for more information.

If you have further questions regarding this error message, please contact Vendini Support at